
WinJammer Player Help Index

WinJammer Player is a program which plays MIDI songs.    It allows you to create "Albums" of 
songs which will be played in sequence.    Because WinJammer Player does all this playing in 
the background, you can now listen to your favorite songs while you do other things.    If you 
are running Windows in extended mode (386 mode), WinJammer Player will even play while 
you are in a DOS session.

WinJammer Player is not a free program, but is being distributed as part of the WinJammer 
package under the Shareware concept.    This allows you to test the program to determine 
whether it is worth anything, and then buy it if you are going to use it.    You must register 
the program if you are going to use it.    See the help topic Registration for registration 
instructions.

This index contains a list of all Help topics available for WinJammer Player.    For information 
on how to use Help, press F1 or choose Using Help from the Help menu.

Quick Start Quick start up help for first time users.
Commands Information on all available commands.
Keys List of the keys used in WinJammer Player.
Registration How to Register WinJammer Player.



Quick Start

Welcome to WinJammer Player.    We will try to get you going as fast as possible by 
describing how to play the sample songs.    The sample songs are all set up for the General 
MIDI specification, so you may have to revoice them using WinJammer before trying to play 
them here.

Configuration

Before you can play a song the MIDI hardware must be configured.    The MIDI Configure 
command is used to do this.    If you've already done this with WinJammer, you don't have to 
do it again.

Creating an Album

WinJammer Player deals with lists of songs to play, called Albums.    It is easy to build an 
album.

1. Clear Album.    The listbox labeled Songs shows the contents of the current album.    It is 
empty when the program is started.    If it is not empty now, use the File New command to 
clear it.

2. Add Songs.    Press the button labeled Add Song.    A dialog will appear listing all of the 
songs in the current directory.    To select a single song, highlight it in the list and press Add.   
The song name will appear in the album.    The button labeled Add All will add all of the 
songs displayed to the album.    When you are finished, press Done or the Esc key.

Playing the Album

Now that we have an album of songs, we can press the Play button and WinJammer Player 
will start to play them in sequence.    Don't be alarmed if the Player suddenly disappears 
when you press Play.    This is so that you can go and do other things while it plays.    This is 
controlled by the Minimize switch on the Options menu.

Stopping Play

Play will stop at the end of the album unless the Loop switch is used.    Play can be stopped 
by pressing the Stop button, or selecting Stop from the system menu.



Commands

This index contains a list of the Help available on the various WinJammer Player Commands. 
For information on how to use Help, press F1 or choose Using Help from the Help menu.

File Menu Create, Load or Save Albums.
Options Menu Change WinJammer Player Options.
Main Window Work with an Album.



Keys

The following keys may be used as short cuts for various commands.

F1 Help
Ctrl+O Open a New Album.
Ctrl+S Save the Current Album
Ctrl+A Save the Album after Asking for a File Name
Del Delete the Selected Song
Ins Insert a New Song



Registration

As discussed in the index, WinJammer Player is being distributed as part of the WinJammer 
package through Shareware.    This allows you to evaluate the program to see if it performs 
properly, before you have to pay for it.    It does not allow you to "evaluate" the program 
forever - if you use it after evaluating it for a week or two, then you must register.

To register WinJammer send me a note and a cheque or money order for $50 US.    Please 
include in your note your name, mailing address, current version number and computer/MIDI
setup.    The current version information is found in the Help About dialog box.    If you would 
like a copy mailed to you, please add an additional $5, and I will send you the most recent 
version available.    Please note that registration for WinJammer includes registration for 
WinJammer Player.

I will send your registration keys, which you can then use with the File Register command to 
unlock the program.    If you have a CompuServe account, I will send the registration keys 
immediately via CompuServe mail, otherwise I will have to send you an old fashioned letter.

I can be reached at:
Dan McKee
69 Rancliffe Road
Oakville, Ontario
Canada
L6H 1B1

Please ensure that you use the correct postage.    It currently costs 40 cents to mail a letter 
from the US to Canada.    I know a number of people have had their letters returned because 
of insufficient postage.

Software Excitement!

The good folks at Software Excitement! will also accept registrations for WinJammer.    They 
accept Visa/Mastercard, and will accept international orders.    If you want a copy of the 
program sent to you, they can also do this for a nominal charge.

Software Excitement! can be reached a number of ways.    If you are a member of 
CompuServe, they have a store in the "Electronic Mall" (GO SE) that you can use for free.    
They will also take orders via normal mail, phone or fax at:

Software Excitement! (Attn: Registrations)
6475 Crater Lake Highway
Central Point, OR 97502

Toll Free Phone: (800)444-5457
Fax Number: (503)826-8090
Non-Toll Free: (503)826-8082

MIDILIB.DLL

A substantial amount of the effort that went into WinJammer was actually spent developing 
MIDILIB.DLL - the code that actually runs the MPU-401.    If you are trying to develop a 
Windows program that uses a MIDI device, I may be able to help you out.

I am selling a developer's kit so that you can write your own Windows based MIDI programs.  
This kit includes: printed documentation for the library, the needed include/library files, 
some example programs with source, a registered copy of WinJammer and limited 
distribution rights for MIDILIB.DLL.    The price for the kit is $100 US, and any registration 



fees paid for WinJammer are deductible from this price.

You will be able to distribute your programs through Shareware channels as long as you 
make a registered copy of your program available to me.    I will advertise your product with 
all of the Shareware MIDI programs that I produce.    You will have to acknowledge me as the 
author of MIDILIB.DLL, and place certain information in your program's About box.

If you are interested in distributing MIDILIB.DLL in a commercial product, a separate 
negotiated license is required.    Please give me a call to discuss this.    If necessary, I will 
customize a DLL for you.

The*Drums

The first Shareware product using MIDILIB.DLL written by someone other than me has 
recently been released.    This is a great program called The*Drums, written by Fabio 
Marzocca.    Fabio's description of his program is:

New The*Drums V3.00 for Microsoft Windows!    Universal Editor/Sequencer for drum 
parts.    Build your own drum patterns and songs, and save them as Standard Midi File
Format.

Check it out!

Support (How to contact me)

There are a number of channels that you can use to contact me.    My CompuServe id is 
70742,2052.    A message there will reach me if sent via mail or if left in the MIDIFORUM.    I 
can also be reached on Internet as 70742.2052@compuserve.com.

I monitor the MIDI conferences on SmartNet, Rime, NorthAmeriNet, Intelec, and Interlink.    
Address messages it to me to be sure I see it.

I can be reached by telephone at (416)844-1821.    Please try to call between the hours of 7 
and 9 PM, Eastern Time.    If all else fails, you can always write me at the address above.



File Menu

The File menu includes commands that enable you to load or save albums, or create a new 
album.    To WinJammer Player, an album is a list of the songs that you would like played.

For more information about a File Menu command, select one of the following topics.

New Create a New Album.
Open Loads an Album File.
Save Saves the Current Album.
Save As Saves the Album under a Different Name.
Configure Configures the MIDI Device.
Register Registers your copy of WinJammer.
Exit Exits WinJammer Player.



Options Menu

The Options menu includes commands which effect the operation of WinJammer Player.    All 
of these options are stored when you exit so that next time you use WinJammer Player you 
do not have to customize WinJammer Player again.

For more information about one of the Options Menu commands, select one of the following 
topics.

Loop Continuous Play.
Reset Send Reset Commands between songs.
Minimize Turn into an Icon when Playing.
Delay Set a delay between songs.



Main Window

The Main Window contains the controls used to manipulate an album of songs, along with 
the controls which control the playback.

For more information about one of the Main Window controls, select one of the following 
topics.

Add Song Add a Song to the Album.
Delete Song Delete a Song from the Album.
Play Start the Album Playing.
Next Song Skip to Start of Next Song.
Stop Stop the Playback.
Pause Pause the Playback.



File New Command

The File New command is used to clear the current album from memory.    It deletes all 
songs, and reinitialises the system to its start up state.

If you have not saved the last changes you made to the current album, WinJammer Player 
will ask you if you would like to save them before clearing the album.



File Open Command

The File Open command is used to load an album from disk.    It replaces the current album 
in memory.

If you have not saved the last changes you made to the current file, WinJammer Player will 
ask you if you would like to save your changes before loading the new album.

Short Cut Key: Ctrl+O



File Save Command

The File Save command saves the current album using the current file name.    If there is no 
current file name, the File Save command is the same as the File Save As command.    If a 
song was previously named using the File Save As command or if the file was loaded using 
the File Open command, then the file on disk is overwritten by the album.

Short Cut Key: Ctrl+S



File Save As Command

The File Save As command saves the current album, after prompting for a file name.    If the 
entered file name exists, WinJammer Player will prompt before overwriting the file.

Short Cut Key: Ctrl+A



File Configure Command

This command is used to configure WinJammer Player for the hardware on your particular 
machine.    You must do this before you can play any songs.

The dialog box displayed is used to select the devices to be used.    The list of available 
devices will depend on the drivers you have installed.    Simply select the desired input and 
output devices, then press Ok.    It is possible to reconfigure WinJammer whenever you 
choose.

Control Panel

The Windows Control Panel application is used to configure Windows for your equipment.    
There are two steps required to set up MIDI devices.

1. Install the drivers.    The first step is to install drivers for your hardware.    This is done 
through the Drivers icon in the Control Panel.    When first started, you will be presented with 
a list of the installed drivers.    Press the Add button to add more drivers to the list.    
Depending on the driver, you may be asked for hardware configuration information.    Once 
all of the drivers are added, you will have to restart Windows to make the new drivers 
available.

2. Configure the MIDI Mapper.    The MIDI Mapper is a special MIDI output device that is used 
to remap songs from the General MIDI Specification to whatever equipment you have.    You 
can start the MIDI Mapper by clicking on the icon in the Control Panel.    The dialog shown will
allow you to select your setup from one of the defaults.    If you get a message saying that 
the current setup references a device that you don't have installed, then you'll have to either
edit the configuration or choose a different one.    See your Windows manual for more 
details.

WinJammer MIDI Configuration

Now that the proper devices are installed, you can use the MIDI Configure command in 
WinJammer to select the appropriate input and output device.



File Register Command

The File Register command is used to register your copy of WinJammer, which includes 
WinJammer Player.    Once registered, the reminder dialog will no longer appear.    The track 
name field will also be able to be entered and saved, and the About box will display the 
registration information.

To register the program, you must carefully enter the registration information.    Please take 
care to enter the three fields exactly as I sent them to you, or the registration will fail.

For more information on registration, including the cost and how to do it, see the 
Registration topic.



File Exit Command

The File Exit command will terminate WinJammer Player, and return to Windows.    If the last 
changes to the current album have not been saved, WinJammer Player will ask if you would 
like to save them before exiting.

WinJammer Player will not let you exit or shut down Windows if an album is currently 
playing.    You must stop play first.



Options Loop Switch

The Loop switch specifies what WinJammer Player is to do at the end of the album.    If this 
switch is on (checked), playback will start again with the first song in the album.



Options Reset Switch

The Reset switch is used to tell WinJammer Player to send out a reset sequence at the 
beginning of each song.    This can be very useful if a song changes a controller, and the 
following song doesn't reset it.

The following MIDI reset sequence is transmitted on all channels:

Bx 7B 00 ;all notes all
Bx 01 00 ;modulation wheel to zero
Bx 07 7F ;volume to max (127)
Bx 40 00 ;sustain pedal off
Ex 00 40 ;centre pitch wheel



Options Minimize Switch

The Minimize switch is used to ask WinJammer Player to minimize (turn into an icon) when 
playback is started.    This is handy when you are playing a number of songs in the 
background.



Options Delay Command

The Delay command is used to set up a time delay between songs during playback.

The dialog which appears allows you to set a delay between songs in seconds.



Add Song Command

The Add Song pushbutton is used to add one or more song to the album.    When the 
pushbutton is pressed, or the Ins key is pressed, a dialog box is presented allowing you to 
select one or more song to add to the album.    The Add All button will add all of the listed 
songs to the album.    Press Done when you have added all of the songs.

Short Cut Key: Ins



Delete Song Command

The Delete Song pushbutton is used to delete the currently selected song.    Simply select 
the song you wish to delete from the album in the listbox, then press the Delete Song button
or press the Del key.

Short Cut Key: Del



Play Command

This command will start the playing of the current album.    Playback starts with the currently
selected song, or the first song in the album.

The system menu (pull down from close box or clicking on Icon) includes this command.    
This makes WinJammer Player easy to control when it is minimized.



Next Song Command

The Next Song commands causes the currently playing song to be stopped immediately.    If 
there is another song in the album, the album will continue playing with this next song.

The system menu (pull down from close box or clicking on Icon) includes this command.    
This makes it easy to skip to the next song while the album is playing in the background.



Stop Command

The Stop command stops the play of the album immediately.

The system menu (pull down from close box or clicking on Icon) includes this command.    
This facilitates shutting down Windows while an album is playing.



Pause Command

The Pause command stops the play of the album immediately.    The next time that Play is 
pressed then the playback of the current song will continue.

The system menu (pull down from close box or clicking on Icon) includes this command.    
This is often convenient when running WinJammer Player minimized.


